Digital Spy

Search Digital Spy
 

DS Forums

 
 

Windows Picture Viewer (Vista)


Reply
Thread Tools Search this Thread
Old 18-04-2012, 19:12
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454

Is there a way of stopping the Windows Picture Viewer (when you click on a picture and press PREVIEW) from opening large every time I open a picture within it?

I am trying to set the box up so it sits beside another program on Vista (Word) but when I open a new picture (right-click, preview) it always opens up full screen.

Any help would be appreciated.
Kassiknorr v2.0 is offline   Reply With Quote
Please sign in or register to remove this advertisement.
Old 18-04-2012, 19:27
REDBUS
Forum Member
 
Join Date: Jan 2010
Posts: 1,969
Only thing i can think of is when pic opens full screen click the middle button on top right hand corner to see if this set's the size next time you open a pic as this work's for a lot of app's.

Know you've maybe tried this ,apology's ,but have no pic's to try (use vista as well).
REDBUS is offline   Reply With Quote
Old 18-04-2012, 20:07
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454
Yeah, gave that a try. It seems to decrease the size, but only to the middle of the entire desktop. I need it to resize to the last size I used before shutting it down. I'm sure I was able to do it before, but can't remember the method I used to make it stick.

Thanks for answering.
Kassiknorr v2.0 is offline   Reply With Quote
Old 19-04-2012, 07:57
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454
It's strange, but I have been on numerous other websites (including a Windows expert site) and no one seems to know how to do it. My brother managed it on his Vista laptop, and doesn't remember what he did.

I'm beginning to think I imagined it.
Kassiknorr v2.0 is offline   Reply With Quote
Old 19-04-2012, 09:18
flagpole
Inactive Member
 
Join Date: Jan 2003
Posts: 43,524
i think the file association on for example .jpg looks something like this
%SystemRoot%\System32\rundll32.exe "%ProgramFiles%\Windows Photo Viewer\PhotoViewer.dll", ImageView_Fullscreen %1

a quick search on my win 7 machine shows for example shows
[HKEY_CLASSES_ROOT\jpegfile\shell\open]
%SystemRoot%\System32\rundll32.exe "%ProgramFiles%\Windows Photo Gallery\PhotoViewer.dll", ImageView_Fullscreen %1

so what i'm basically saying is that it's not that the app is forgetting it's location it's that windows, in addition to handing the file to photoviewer is also giving it the option 'ImageView_Fullscreen' -

so when you double click a jpeg in addition to windows saying right with a jpeg i pass that file to this program for viewing, it is also passing the command line option to view full screen
flagpole is offline   Reply With Quote
Old 19-04-2012, 09:31
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454
Is there a way to stop it doing that?
Kassiknorr v2.0 is offline   Reply With Quote
Old 19-04-2012, 09:46
flagpole
Inactive Member
 
Join Date: Jan 2003
Posts: 43,524
Is there a way to stop it doing that?
i can think of a few things to try.

if you search the registry for ImageView_Fullscreen and modify the entries where you see it that should work.

it might work if you break the association with windows photoviewer by associating it with something else and then go back to windows photo viewer.

some kind of file types editor might work. actually i've just tried this and it's probably the easiest way i use this http://defaultprogramseditor.com/

go to file type settings
context menu
select the extension we are interested in eg .jpg
the top command in bold is the one we are interested in. called Preview for images
select it and click edit selected command
on the drop down on the right click the little arrow and select command line
remove ImageView_Fullscreen fromthe command line leaving the %1 bit
click next and continue.
flagpole is offline   Reply With Quote
Old 19-04-2012, 10:13
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454
Thanks for the program. Once I have downloaded it, where do I put it when I unzip it?
Kassiknorr v2.0 is offline   Reply With Quote
Old 19-04-2012, 10:24
flagpole
Inactive Member
 
Join Date: Jan 2003
Posts: 43,524
anywhere. on your desktop is fine.
flagpole is offline   Reply With Quote
Old 19-04-2012, 10:29
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454
Thanks. Going to give it a try now. Appreciate the help.
Kassiknorr v2.0 is offline   Reply With Quote
Old 19-04-2012, 10:35
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454
Little problem... it won't open the pictures at all now.
Kassiknorr v2.0 is offline   Reply With Quote
Old 19-04-2012, 11:44
flagpole
Inactive Member
 
Join Date: Jan 2003
Posts: 43,524
Little problem... it won't open the pictures at all now.
oh dear.

right click an image
open with >
choose default program...
and select the windows thing. be sure to check 'always use this program'
flagpole is offline   Reply With Quote
Old 19-04-2012, 22:15
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454
oh dear.

right click an image
open with >
choose default program...
and select the windows thing. be sure to check 'always use this program'
I had to put the Fullscreen part back in. It just wouldn't let me open a preview even when I chose the default program with it.
Kassiknorr v2.0 is offline   Reply With Quote
Old 20-04-2012, 08:15
Kassiknorr v2.0
Forum Member
 
Join Date: Jun 2009
Location: Dagenham
Posts: 454
Woke up this morning and it seems it worked regardless. Ressetting the registry through that program had the unknown effect of making the pictures come out as they were before.

Thanks flagpole.
Kassiknorr v2.0 is offline   Reply With Quote
Old 20-04-2012, 08:35
flagpole
Inactive Member
 
Join Date: Jan 2003
Posts: 43,524
so long as it worked.
flagpole is offline   Reply With Quote
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

 
Forum Jump


All times are GMT +1. The time now is 12:05.