Digital Spy

Search Digital Spy
 

DS Forums

 
 

Problem with my iPod Nano - won't connect to iTunes


Reply
Thread Tools Search this Thread
Old 07-02-2014, 00:06
ShaunIOW
Forum Member
 
Join Date: Jun 2006
Location: Isle of Wight
Posts: 5,349

I've got an iPod Nano 16Gb 7th Gen version, bought in December.

It's been working fine, but I want to add another couple of albums to it, but when I connect to iTunes I get the following message

An iPod has been detected, but it could not be identified properly. Please disconnect and reconnect the iPod then try again.

If the problem persists, uninstall iTunes, then reinstall iTunes again
I've tried uninstalling/reinstalling iTunes, stopped/started iTunes services, reset the settings on the Nano, different USB ports and nothing helps.

I tried it on my laptop PC as well with a different cable and its exactly the same even after going through all the same 'fixes' as I'd tried on the desktop.

Both PC's are running Windows 8.1, but on the laptop the iPod showed up as a drive in Explorer (although not usable), but on the desktop it doesn't - although the PC does detect an iPod has been connected and assign it a drive letter.

It was setup on my desktop PC in December when it was running Windows 7 Pro, but I've since reformatted and put on Windows 8.1 Pro, and am running the latest 64 bit versions of iTunes on both PC's.

I can't go to an Apple store as A) There isn't one on the Island and B) I'm agoraphobic and don't go out anyway.

Any ideas?

Cheers
ShaunIOW is online now   Reply With Quote
Please sign in or register to remove this advertisement.
Old 07-02-2014, 00:29
Mystic Eddy
Forum Member
 
Join Date: Apr 2006
Posts: 3,665
Have you tried the trouble shooting steps on Apple's website? If they don't work, you can send it off for service. Apple will send you a box that you put it in and then post it to their servicing facility.
Mystic Eddy is offline   Reply With Quote
Old 07-02-2014, 07:50
Kargo
Forum Member
 
Join Date: Oct 2005
Location: Essex, UK
Posts: 5,815
Try a soft reset (you won't lose any songs)

Press and hold the Sleep/Wake button and the Home button until the screen goes dark. The Apple logo should appear after a few seconds, then the Home screen should appear.

Then plug it into your PC and see if iTunes detects it.
Kargo is offline   Reply With Quote
Old 07-02-2014, 16:07
ShaunIOW
Forum Member
 
Join Date: Jun 2006
Location: Isle of Wight
Posts: 5,349
Have you tried the trouble shooting steps on Apple's website? If they don't work, you can send it off for service. Apple will send you a box that you put it in and then post it to their servicing facility.
Went through all that and nothing worked

Try a soft reset (you won't lose any songs)

Press and hold the Sleep/Wake button and the Home button until the screen goes dark. The Apple logo should appear after a few seconds, then the Home screen should appear.

Then plug it into your PC and see if iTunes detects it.
Tried that.

In the end I uninstalled everything Apple related and not just iTunes and reinstalled and that seems to have worked, although it did mean having to restore the Nano to factory settings and re-sync all my music.
ShaunIOW is online now   Reply With Quote
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

 
Forum Jump


All times are GMT +1. The time now is 05:39.