Digital Spy

Search Digital Spy
 

DS Forums

 
 
 

Samsung Smart TV and ITV Player


Reply
Thread Tools Search this Thread
Old 14-11-2012, 17:11
Stuart_h
Forum Member
 
Join Date: Jul 2005
Posts: 2,484

I have a Samsung Smart TV. ITV Player is installed but when I try and watch something I only ever get a black screen. It used to work fine. Im on the latest firmware and the latest app version

I have a Samsung Smart Blu-Ray player .... ITV Player isnt even available for that one

anyone else having ITV Player issues ???
Stuart_h is offline   Reply With Quote
Please sign in or register to remove this advertisement.
Old 14-11-2012, 17:25
ftsemonks
Inactive Member
 
Join Date: May 2012
Posts: 530
I have a Samsung Smart TV. ITV Player is installed but when I try and watch something I only ever get a black screen. It used to work fine. Im on the latest firmware and the latest app version

I have a Samsung Smart Blu-Ray player .... ITV Player isnt even available for that one

anyone else having ITV Player issues ???
Yes...... If I was you I would get the latest Sky+HD Box like me and then you can watch catch up tv with 4OD coming early next year.
At the momemt BBC-IPlayer is great but the 5 On-demand is Rubbish
ftsemonks is offline   Reply With Quote
Old 14-11-2012, 17:50
Sue_Aitch
Forum Member
 
Join Date: Mar 2010
Posts: 4,712
I have a Samsung Smart TV. ITV Player is installed but when I try and watch something I only ever get a black screen. It used to work fine. Im on the latest firmware and the latest app version

I have a Samsung Smart Blu-Ray player .... ITV Player isnt even available for that one

anyone else having ITV Player issues ???
Have you checked with the manufacturer as it could be simply a glitsch?
Sue_Aitch is offline   Reply With Quote
Old 14-11-2012, 22:00
Stuart_h
Forum Member
 
Join Date: Jul 2005
Posts: 2,484
Yes...... If I was you I would get the latest Sky+HD Box like me and then you can watch catch up tv with 4OD coming early next year.
At the momemt BBC-IPlayer is great but the 5 On-demand is Rubbish
Just got rid of sky ...... Netflix now at a fraction of the price
Stuart_h is offline   Reply With Quote
Old 14-11-2012, 22:01
Stuart_h
Forum Member
 
Join Date: Jul 2005
Posts: 2,484
Have you checked with the manufacturer as it could be simply a glitsch?
Thanks ..... I was just wondering if its a general Samsung bug at the most or just me.
Stuart_h is offline   Reply With Quote
Old 16-11-2012, 14:00
XxBlaKOuTZxX
Forum Member
 
Join Date: May 2011
Location: Edinburgh / Scotland
Posts: 2,773
Which Samsung TV model do you have and have you checked their site to make sure you DO have the latest firmware installed ?. I have the D6530 and it's working fine for me (just tried it)
XxBlaKOuTZxX is offline   Reply With Quote
Old 18-11-2012, 14:59
itvplayer
Forum Member
 
Join Date: Nov 2012
Posts: 3
I am having the same problem as theOP.
Mine Samsung UE40D7000LUXXU.
Upuntil last month the itvplayer worked well on software v 001021.
It would just turn to black screen and researching on the Samsung suggested new firmware. Installed using USB to the latest firmware and now has v001025 but the itvplayer would not work.
By the way the BBC iplayer works without any issues.

Home wireless internet works well and we could watch the itvplayer on our apple iPad using the wireless network through the web-browser.

Contacted the Samsung & itv both of them on the phone tried all what we have attempted ourselves and no solutions found yet.

Is it ITV or Sansung to be blamed? Something is wrong....
itvplayer is offline   Reply With Quote
Old 20-11-2012, 23:54
durtylinen
Forum Member
 
Join Date: Nov 2012
Posts: 3

I have a UE37ES5500 purchased in July with ITV player pre-installed. ITV player has never worked. It starts, but quickly crashes giving an error message [SAMITV-102]. The set came with firmware 1018, but I've updated this three times and am now on 1025. I've also uninstalled and reinstalled ITV player to no avail. Has anyone got it working on this model?
durtylinen is offline   Reply With Quote
Old 21-11-2012, 00:20
Roush
Forum Member
 
Join Date: Mar 2011
Location: Hertfordshire
Posts: 2,208
I have a UE32ES5500 purchased this summer, which came without ITV Player.

I now have ITV Player installed and fully working, and I'm running the following versions:

Firmware: 001029
Smart Hub: 4.4521-5.0
ITV Player: 12.170


I have a UE37ES5500 purchased in July with ITV player pre-installed. ITV player has never worked. It starts, but quickly crashes giving an error message [SAMITV-102]. The set came with firmware 1018, but I've updated this three times and am now on 1025. I've also uninstalled and reinstalled ITV player to no avail. Has anyone got it working on this model?

In theory, my TV is the same as yours only with a smaller screen, so check to see if the 001029 firmware is available for your TV.

I used the online update service on the TV to update.
Roush is offline   Reply With Quote
Old 21-11-2012, 21:21
durtylinen
Forum Member
 
Join Date: Nov 2012
Posts: 3
I have a UE32ES5500 purchased this summer, which came without ITV Player.

I now have ITV Player installed and fully working, and I'm running the following versions:

Firmware: 001029
Smart Hub: 4.4521-5.0
ITV Player: 12.170





In theory, my TV is the same as yours only with a smaller screen, so check to see if the 001029 firmware is available for your TV.

I used the online update service on the TV to update.
Thanks for trying. I now have the same configuration, apart from Smart Hub being 4.5021, presumably even more up to date???

Still same ITV player problem. BBC iPlayer is fine. Time to try helpline, but not holding my breath! Strange that ITV player is the only component anyone seems to be having a problem with.
durtylinen is offline   Reply With Quote
Old 24-11-2012, 09:18
XxBlaKOuTZxX
Forum Member
 
Join Date: May 2011
Location: Edinburgh / Scotland
Posts: 2,773
I hope the Smart TV owner's who are having trouble with ITV player aren't too disappointed when they finally get it working only to discover that none of ITV's content is in HD. Total waste of time.
XxBlaKOuTZxX is offline   Reply With Quote
Old 24-11-2012, 11:35
tealady
Forum Member
 
Join Date: Apr 2005
Location: colchester
Posts: 10,322
The ads work fine, but the programmes don't!
tealady is offline   Reply With Quote
Old 30-11-2012, 23:02
malden75
Forum Member
 
Join Date: Nov 2012
Posts: 2

I purchased a Samsung UE46ES8000UXXU LED TV at the beginning of October this year, I have not been able to get my ITV player to work. Contacted Samsung they said it was ITV, ITV said it was Samsung fault. Emailed Samsung 6 times and phoned them 5 times, spoke to ITV twice, Samsung sent out a USB pen, which seems to be for a BBC iplayer. When going onto the ITV player app, whilst in the process of entering the postcode, it cuts off and comes up with [SAMITV-102] fault - Do anyone have any ideas?
malden75 is offline   Reply With Quote
Old 07-12-2012, 21:11
durtylinen
Forum Member
 
Join Date: Nov 2012
Posts: 3
I purchased a Samsung UE46ES8000UXXU LED TV at the beginning of October this year, I have not been able to get my ITV player to work. Contacted Samsung they said it was ITV, ITV said it was Samsung fault. Emailed Samsung 6 times and phoned them 5 times, spoke to ITV twice, Samsung sent out a USB pen, which seems to be for a BBC iplayer. When going onto the ITV player app, whilst in the process of entering the postcode, it cuts off and comes up with [SAMITV-102] fault - Do anyone have any ideas?
Hopeless. Similar experience. We don't apear to be alone in this, so why haven't they bottomed it? Should we go to trading standards?
durtylinen is offline   Reply With Quote
Old 13-12-2012, 15:51
Steve_Whelan
Forum Member
 
Join Date: Apr 2005
Posts: 1,705
Hopeless. Similar experience. We don't apear to be alone in this, so why haven't they bottomed it? Should we go to trading standards?
The Apps like ITV player are software made by a third party, compatibility is not guaranteed, The electronics companies use the old subject to availability clause as a legal getout, so not a trading standards issue.
Steve_Whelan is offline   Reply With Quote
Old 13-12-2012, 19:00
James-30
Forum Member
 
Join Date: Mar 2010
Posts: 58
Working fine for me. Just checked
James-30 is offline   Reply With Quote
Old 14-12-2012, 18:43
noname2
Forum Member
 
Join Date: May 2009
Posts: 77
I recently got ue40es5500 and ITV player does not work (error SAMITV-102). I got round the problem by using one of my raspberry pi's and installing xbmc to view itv, 4od and chanel5.

This setup works well but I shouldn't have to do this as I paid nearly 500 for the TV and it does not work correctly.
noname2 is offline   Reply With Quote
Old 20-12-2012, 17:10
tim3057
Forum Member
 
Join Date: Dec 2012
Posts: 1
James-30 How is it working? What did you do?
tim3057 is offline   Reply With Quote
Old 25-12-2012, 12:13
noname2
Forum Member
 
Join Date: May 2009
Posts: 77
Smart hub has just updated and now ITV Player is working!
noname2 is offline   Reply With Quote
Old 30-12-2012, 15:25
Sprotte
Forum Member
 
Join Date: May 2012
Posts: 2
Hi, my ITV player has stopped working as well. All I get is a black screen as described by Stuart_h and others. I am able to launch the menu but that is it. I had a similar problem with the iPlayer and 2 engineer visits later it is still temperamental but seems to be sorting itself out. They didn't have an answer though!
I have booked an engineer for January hoping to get an answer, Samsung helpline are rather clueless.
The software is 2003.4 which I believe is the latest version as the TV is telling me so. However, when trying to do a Software Update online, I am getting the message:
Failed to connect. . (error Code: 709 invalid parameter) The latest update is not yet available on the server.
All very strange ... getting fed up
Any ideas?
Thanks!!
Sprotte is offline   Reply With Quote
Old 13-02-2013, 16:21
malden75
Forum Member
 
Join Date: Nov 2012
Posts: 2

We were having big problems with the ITV Player. Samsung or ITV could not help. Initally I was using Talk Talk Broadband, then I tried Three Broadband. Now I am on Virgin Broadband, with a Lan cable to the modem and now I can get the ITV Player. It can sometimes be a bit temperamental. So in my case it looks like it must have been down to my broadband provider. Hope this may be of help to someone else.
malden75 is offline   Reply With Quote
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

 
Forum Jump


All times are GMT +1. The time now is 14:53.