Digital Spy

Search Digital Spy
 

DS Forums

 
 

No sound when connecting virgin box to tv with HDMI cable


Reply
Thread Tools Search this Thread
Old 18-01-2013, 23:38
mcgvil
Forum Member
 
Join Date: Nov 2009
Posts: 317

I'm really hoping someone here can help with this because i have no clue how to fix it! I have a bush 42" hd plasma that i can get both sound and picture through when i connect my virgin media box to with a scart lead. But when i try to connect them with a hdmi cable i can only get the picture with no sound at all. I have tried two hdmi cables in all the ports and i have followed the instructions on the tv and virgin media to get the correct settings but i still cannot recieve sound from the HDMI cable. Is there any way i can fix this?
mcgvil is offline   Reply With Quote
Please sign in or register to remove this advertisement.
Old 19-01-2013, 12:19
chrisjr
Forum Member
 
Join Date: May 2004
Location: Reading
Posts: 22,055
I'm really hoping someone here can help with this because i have no clue how to fix it! I have a bush 42" hd plasma that i can get both sound and picture through when i connect my virgin media box to with a scart lead. But when i try to connect them with a hdmi cable i can only get the picture with no sound at all. I have tried two hdmi cables in all the ports and i have followed the instructions on the tv and virgin media to get the correct settings but i still cannot recieve sound from the HDMI cable. Is there any way i can fix this?
You say you have gone through the settings but just to double check. The audio output of the Virgin box should be set to stereo PCM if you have a choice of formats. That is most likely to work with the TV. Any multichanel or Dolby Surround options probably won't be understood by the TV.

Assuming the output format is correct but hasn't cured the problem. The way to sort this is to use substitution to narrow down where the fault lies.

You have swapped cables so barring the possibility that you have two faulty cables that tends to rule the cable out. In any case the audio data is embedded into the video data so a cable is unlikely to affect only the audio and not the video.

Do you have anything else with HDMI, DVD, Blu-Ray, Freeview PVR etc? Try that connected in place of the Virgin box. If you get sound out of that then it suggests it's the Virgin box. If no sound then it is pointing to the TV.

Possibly less easy is to plug the Virgin box into something else to see if it is producing sound. Unless you know of someone with Virgin TV you can't really take it somewhere else to try on a neighbours TV for instance. So you might have to bring another TV to the box to try it on.

Essentially the problem is likely to be one of three things. Faulty Virgin box, faulty TV or settings error. You just have to work out which.
chrisjr is offline   Reply With Quote
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

 
Forum Jump


All times are GMT +1. The time now is 11:14.