DS Forums


Humax HDR 1Tb disk problem

Thread Tools Search this Thread
Old 20-02-2013, 11:51
Forum Member
Join Date: Dec 2008
Posts: 133

This is for info, as I've solved the problem. I just wondered whether anyone else has had something similar.

A friend called me with sick HDR - one I had upgraded to 1Tb for him a couple of years ago with a WD10EVVS. He had been away for some time & left the recorder with a record schedule set up, including series records. When he got back & switched it on, it came up asking to re-format the disk Unfortunately he did so, and lost all his recordings. So he brought it round and asked if I could recover any of the recordings. Anyway, I took the disk out, put it in a eSATA caddy & plugged it into my Linux box. All 4 partitions took many seconds to mount - much longer than normal. I was hoping that the inode tables would be intact so I could recover the files, but unfortunately re-making a ext2/3 filesystem zeros all the inode tables so all reference to which blocks belong to which files is lost
I interrogated the SMART diagnostic stuff on the disk but that didn't look unusual, and a SMART test passed OK. When I re-created the ext3 filesystems the transfer rate was very low. Eventually I ran mkfs.ext3 -c -c ..., which does a complete bad blocks write/read check with 4 different patterns before creating the filesystem (took over 24 hours on the large partition!), and now the disk seems to be behaving itself perfectly. I did wonder if it was a temperature issue, as his house would have got quite cold whilst he was away. Certainly it was working well once it got really warm.
jcsager is offline   Reply With Quote
Please sign in or register to remove this advertisement.

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

All times are GMT +1. The time now is 00:44.