Digital Spy

Search Digital Spy
 

DS Forums

 
 

disabling javascriptvoid - how?


Reply
Thread Tools Search this Thread
Old 19-07-2013, 23:03
amyawake
Forum Member
 
Join Date: Jun 2010
Posts: 1,812

I got this damn javascriptvoid tab/window appearing - totally blank page - that totally crippled my ability to type in any website in the URL, i.e. no typing appears!! Have never heard of this. Eventually normality was restored by switching pc off and back on again. (Before I did that it wouldn't allow typing a post on forums either).

Google search gives confusing info re. how to disable it.I am in google chrome and have no java files. Anyone know procedure to stop it occurring again?
amyawake is offline   Reply With Quote
Please sign in or register to remove this advertisement.
Old 19-07-2013, 23:30
flagpole
Inactive Member
 
Join Date: Jan 2003
Posts: 43,524
Java and JavaScript are not related to each other.

But I don't know what is causing your problem.
flagpole is offline   Reply With Quote
Old 20-07-2013, 00:45
bspace
Forum Member
 
Join Date: Jul 2004
Posts: 8,589
possibly something to do with pop up blocker, see

http://googlechromesupportnow.com/di...from-browsers/
bspace is online now   Reply With Quote
Old 20-07-2013, 10:02
amyawake
Forum Member
 
Join Date: Jun 2010
Posts: 1,812
Thanks but this is not the same thing as javascriptvoid! The instructions given here delete javascipt - javascriptvoid is not mentioned. It isn't recommended to delete javascript, e.g. can't use italics, underline, bold.
amyawake is offline   Reply With Quote
Old 20-07-2013, 11:02
JeffG1
Forum Member
 
Join Date: Jan 2005
Location: Newbury
Posts: 4,882
Thanks but this is not the same thing as javascriptvoid!
Which is not the same as javascript(void). The bit in parenthesis is the parameter passed to javascript. In this case there is no parameter, hence 'void'.
JeffG1 is offline   Reply With Quote
Old 20-07-2013, 11:06
chrisjr
Forum Member
 
Join Date: May 2004
Location: Reading
Posts: 22,577
Thanks but this is not the same thing as javascriptvoid! The instructions given here delete javascipt - javascriptvoid is not mentioned. It isn't recommended to delete javascript, e.g. can't use italics, underline, bold.
You must be reading a different link because that is talking about the void error in Javascript.

And I'm not entirely sure what javascript has to do with bold etc as they are simple HTML tags??
chrisjr is offline   Reply With Quote
Old 20-07-2013, 11:13
flagpole
Inactive Member
 
Join Date: Jan 2003
Posts: 43,524
You must be reading a different link because that is talking about the void error in Javascript.

And I'm not entirely sure what javascript has to do with bold etc as they are simple HTML tags??
I think they are referring to things like the bold and italic buttons in editors on forums and things like that.
flagpole is offline   Reply With Quote
Old 20-07-2013, 16:42
amyawake
Forum Member
 
Join Date: Jun 2010
Posts: 1,812
I think they are referring to things like the bold and italic buttons in editors on forums and things like that.
Yes precisely....posts on forums, i.e. here too!

My point is that I followed the instructions given in post 3 (disabling javascript, i.e. javascriptvoid is not mentioned in the content settings). Whilst posting a thanks I quickly learnt what I had disabled since I couldn't underline or italic any words here.

Perhaps javascriptvoid isn't something that can be disabled. I seem to be learning that it occurs when an error is made, e.g. something not put in { } as it should be (?). Can anyone throw any light on this? If I am right, then if it occurs again (to anyone else too) just shut pc and open again.
amyawake is offline   Reply With Quote
Old 20-07-2013, 21:40
Sambda
Forum Member
 
Join Date: Mar 2005
Posts: 2,007
Which is not the same as javascript(void). The bit in parenthesis is the parameter passed to javascript. In this case there is no parameter, hence 'void'.
I think you mean "javascript:void(0)". When you want to handle a clicked link with JS and not just got to the URL in your href argument, you put javascript:void(0) in as the href of the <a> tag. Something like this:

Code:
<a href="javascript:void(0)" onclick="hideouspopup()">This is what you click on</a>
When you mousover such a link, in your browser's indicator of where a link will take you if clicked (often on one of the status bars in the browser) just says "javascript:void(0)", not actually where/what the event handler is going to do.

Anyhow, OP, if you go to chrome://settings/content#javascript in Chrome, you will find an option there to disable JavaScript for all sites, and a button which will let you disable it on a site-by-site basis.

Having said that, you may then not be able to otherwise navigate to wherever the problematic link was supposed to take you to, or do. It may stop that window popping up and thereby crashing your browser, though.

(NB JavaScript is not the same as Java.)
Sambda is offline   Reply With Quote
Old 20-07-2013, 22:23
amyawake
Forum Member
 
Join Date: Jun 2010
Posts: 1,812
samda - did you read my post 8? Done that - problematic/ineffective
amyawake is offline   Reply With Quote
Old 20-07-2013, 22:33
Sambda
Forum Member
 
Join Date: Mar 2005
Posts: 2,007
samda - did you read my post 8? Done that - problematic/ineffective
Then I don't understand what you are talking about (like most people in this thread, I fear).

Where on your screen is the word/phrase "javascriptvoid" coming up?

Or post the link of the site.

Or furnish us with a far better and lucid description of your problem.
Sambda is offline   Reply With Quote
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

 
Forum Jump


All times are GMT. The time now is 00:27.