Digital Spy

Search Digital Spy
 

DS Forums

 
 

Stop running this script?


Reply
Thread Tools Search this Thread
Old 13-11-2013, 12:13
Sigurd
Guest
 
Join Date: Jul 2004
Posts: 24,445

Several times a day I'm seeing this message:

Stop running this script?

A script on this page is causing your web browser to run slowly. If it continues to run, your computer might become unresponsive.
There's then a Yes/No option for stopping the script.

I'm using Windows 8.1 and Firefox, but the message sometimes seems to appear when I'm not running a browser at all. The problem didn't occur before Windows updated to 8.1. I've run virus and malware scans but the warning message keeps popping up.

Any suggestions as to how to cure the problem? How can I identify which script is to blame?
Sigurd is offline   Reply With Quote
Please sign in or register to remove this advertisement.
Old 13-11-2013, 13:10
tealady
Forum Member
 
Join Date: Apr 2005
Location: colchester
Posts: 10,679
No script Firefox add on will show what scripts are running on a page. You could enable them one by one to see what is the cause.
tealady is offline   Reply With Quote
Old 13-11-2013, 13:13
daver34
Guest
 
Join Date: May 2009
Posts: 813
I used to get this(still occasionally) with firefox, when having to many screens/tabs open. I went to Tools-options-tabs and unticked the 2 warn me boxes.

I also changed to time settings for the warning, follow instructions.

http://robcottingham.ca/2006/05/fire...onsive-script/
daver34 is offline   Reply With Quote
Old 13-11-2013, 13:42
Sigurd
Guest
 
Join Date: Jul 2004
Posts: 24,445
No script Firefox add on will show what scripts are running on a page. You could enable them one by one to see what is the cause.
Thanks. I did install NoScript a few days ago, but since I didn't know which scripts were necessary and which might be causing problems I uninstalled it again. However, I guess that if I want to sort out the problem I may have to give it another go. The curious thing is that when the warning message comes up my browser seems to be operating quite normally!
Sigurd is offline   Reply With Quote
Old 13-11-2013, 13:47
Sigurd
Guest
 
Join Date: Jul 2004
Posts: 24,445
I used to get this(still occasionally) with firefox, when having to many screens/tabs open. I went to Tools-options-tabs and unticked the 2 warn me boxes.

I also changed to time settings for the warning, follow instructions.

http://robcottingham.ca/2006/05/fire...onsive-script/
Thanks. I've unticked the two boxes that you refer to and I'll see if that helps.

On advice from Mozilla Help I had already tried increasing the time setting but that didn't make any difference.

It's more of a minor irritation than a major problem, but I would like to sort it. Maybe the box unticking will do the job!
Sigurd is offline   Reply With Quote
Old 13-11-2013, 17:26
tealady
Forum Member
 
Join Date: Apr 2005
Location: colchester
Posts: 10,679
Thanks. I did install NoScript a few days ago, but since I didn't know which scripts were necessary
I've found you get a couple of obvious ones sitename.co.uk, sitename.com and a couple of ones that are obviously ad related, then a couple in the middle which are unclear as to their use. At least you can temporarily enable them as you go (but not a good idea if you want to pay by debit/credit card - they have to be enabled before the process starts).
tealady is offline   Reply With Quote
Old 13-11-2013, 18:16
fmradiotuner1
Forum Member
 
Join Date: Mar 2008
Location: TheEssexSunshineCoast Clacton
Posts: 12,969
Just came up on my PC about an hour ago never had it before.
fmradiotuner1 is online now   Reply With Quote
Old 13-11-2013, 19:31
Sexbomb
Forum Member
 
Join Date: Jan 2006
Location: Preston
Posts: 12,184
Get a lot of this on facebook.
Sexbomb is offline Follow this poster on Twitter   Reply With Quote
Old 13-11-2013, 20:17
Sigurd
Guest
 
Join Date: Jul 2004
Posts: 24,445
Thanks. I've unticked the two boxes that you refer to and I'll see if that helps.

On advice from Mozilla Help I had already tried increasing the time setting but that didn't make any difference.

It's more of a minor irritation than a major problem, but I would like to sort it. Maybe the box unticking will do the job!
Unfortunately the box unticking hasn't helped and I've had the unresponsive script warning about three times since making the change. The problem does seem very intermittent, though, and I haven't been able to link it to a particular web site or to having a particular number of tabs open. I don't remember seeing it before the Windows 8.1 upgrade, though, and my feeling is that messed something up.

Ah well, maybe if there's a particularly wet weekend I'll take the time to investigate with NoScript or something similar!
Sigurd is offline   Reply With Quote
Old 13-12-2013, 19:10
Sigurd
Guest
 
Join Date: Jul 2004
Posts: 24,445
Just as a matter of interest, the problem that I outlined in the opening post now seems to have stopped, and I haven't seen the "Stop running this script?" message for maybe two or three weeks. Presumably something updated itself, but I don't know what.

Now if Firefox 26.0 would just stop crashing at regular intervals my life would be complete.
Sigurd is offline   Reply With Quote
Old 13-12-2013, 21:35
Sick Bullet
Forum Member
 
Join Date: Mar 2006
Location: Chadderton
Posts: 9,332
I get this every other day it's strange, everything locks up for a few seconds then it's fine.
Sick Bullet is offline   Reply With Quote
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search

 
Forum Jump


All times are GMT +1. The time now is 17:32.